• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Mazda MX5 Forum and Mazda MX5 community dedicated to Mazda MX5 owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Mazda MX5 Forum today!

Unresponsive throttle / lack of power between 40 - 45 MPH

Hi, I have an annoying issue with my 2001 MX5 (1.8 litre, 5 speed manual). Sometimes when I am doing between 40 – 45 MPH in 4th gear and I put the foot down a bit, the throttle is pretty unresponsive and there is a distinct lack of power. A few times when this has happened I have put the pedal fully to the floor to see what happens – and still nothing – no power. After a long while however, the car speeds up, but it is a slow process, not exactly sports car-esque.

I find it weird because other times in 4th gear in the same speed band, I will give the throttle a bit of a push and the car is very responsive and speeds up nicely. So does anyone know why this is happening? Why is it responsive sometimes, and not others?

Some background info: I had a recurrent misfire a while ago, so I had the spark plugs, ignition leads, and coil packs changed, and that solved the issue. The car has felt very good after that, apart from the issue described above. I noticed this intermittent unresponsive throttle issue after I purchased it, right at the point when I was transitioning from a slow speed urban area (40 MPH) to an open road area (60MPH). Just when I wanted some power, my car didn’t seem to have any. I had the car serviced after I got it (oil, plugs, Pipercross air filter) and it felt a lot better, but obviously that throttle / power issue remains the same.

Other things I should mention just in case they are related: Since I got the car, every now and again the car will jerk a little bit as if I have randomly fluttered the accelerator pedal up and down, when in fact I haven’t. Usually only happens for about 2 seconds, maybe once or twice during a one hour drive. Also, the fuel guage has gone wonky; it wasn’t working at all, then I put in half a tank of petrol and the guage stayed on that reading when the engine was off. Then I put in another half a tank and it stayed on full when the engine was off. It reads the correct fuel level, reducing as the amount of fuel reduces, but the guage stays on that level when the engine is turned off. Anyway, because the guage was stuck on empty for a while, I ran out of petrol and the engine warning light came on when that happened. Could that have cause the engine to misfire and damaged a spark plug? After I filled the tank up beyond half, the engine warning light turned off and has stayed off ever since.

Apologies for the length of the post. Does anyone know what is causing this unresponsive throttle / lack of power issue at that speed band? Thanks!!!